Thursday, 13 February, 2020

macOS 10.15 Catalina support for Avid MC and Premiere Pro

If you're planning on getting a new MacBook Pro 16", or any Mac that's pre-loaded with macOS 10.15 Catalina, and plan on editing with Avid Media Composer, here are the limitations of running Avid Media Composer 2020.2 (beta).
Bear in mind that Avid ver 2019.12 or previous versions (like 2018.x versions or even older 8.x.x versions) will not not even install (or launch) in macOS 10.15 Catalina.
Also, note that if your Mac originally had an earlier macOS (like macOS 10.14 Mojave or macOS 10.13 High Sierra or earlier) and you've upgraded to macOS 10.15 Catalina, then you will be able to 'down-grade' your Mac from macOS 10.15 to macOS 10.14 or earlier.
But the MacBook Pro 16" will simply not let you down-grade.
It might be a good idea to get the older MacBook Pro 15" while stocks are still available.
Avid recommends Shutter Encoder to convert incompatible types of files to Avid NDxHD OP-Atom for use inside Media Composer running on macOS 10.15 Catalina
Or, you can use Apple Compressor or Adobe Media Encoder both of which can create MXF OP-Atom files for use in Avid Media Composer.
And this is Adobe's note on 


No comments:

Post a Comment

Place your comment on what I have written here. If you want to ask a a question or expect a response from me consider mailing me. My address is linked in the margin.

If its advice for a commercial project, I may expect to be compensated for a response.